Beginning Microsoft Excel 2007
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ABOUT THIS CLASS
​​​

This class is designed to give a basic introduction into Microsoft Excel 2007. Specifically, throughout the class, we will progress from learning how to open Microsoft Excel to actually creating a document. It is impossible in this amount of time to become totally proficient using Microsoft Excel, but it is our hope that this class will provide a springboard to launch you into this exciting world!  
Course Objectives  

By the end of this course, you will be able to
· Open Excel and create a new worksheet.

· Format columns and rows.

· Apply basic text formatting.
· Know the difference between deleting and clearing a cell.
· Automatically fill in Labels. 

· Merge cells.

· Use Autosum.

· Perform simple mathematical calculations.

· Create simple formulas.

· Print.
This booklet will serve as a guide as we progress through the class, but also can be a valuable tool when you are working on your own. Any class instruction is only as effective as the time and effort you are willing to invest in it. We encourage you to practice between classes. There are computer workshops on Sundays and Wednesdays where you can practice the skills you have learned.

We have also provided several lists of resource materials that can be used for more information or practice at the end of this booklet
Janice Collins

Technology Supervisor

West Palm Beach Public Library

Excel is a spreadsheet program. A spreadsheet is a grid of rows and columns that helps organize, summarize, and calculate data. Spreadsheets are an everyday part of many professions, including accounting, statistical analysis, and project management. You can use Excel to create business forms, such as invoices and purchase orders, among many other useful documents.
This class teaches Microsoft Excel basics. To begin, let’s open Microsoft Excel. You can do this by clicking on Start, All Programs, and Microsoft Excel. Let’s look at the toolbars. 
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This is the Title Bar. It gives the name of the program and the title of the workbook you are using. Since we have just opened up a new workbook and have not saved it with a name, the default title is Book1.
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The Office Logo Button is located at the upper left of the Title Bar. 

Clicking on it will open a dropdown menu that contains many of the 

menu items that used to appear under File in prior versions of Excel.
Right beside the Office Button is the Quick Access Toolbar. You can 

Add or subtract commands to the toolbar by simply clicking/ on 
them in the list.
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Next we have the Ribbon. The Ribbon has seven Tabs that give instructions to the software. The Ribbon Tabs begin with Home and continue with Insert, Page Layout, Formulas, Data, Review, and View. On the right-hand end, there is an icon for the Help Menu, Minimize, Restore Down, and Close.
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Clicking on one of these Tabs will open the Group. The Group that belongs to each Tab shows related Command items together. You may then choose a Command.

Workbooks and Worksheets

When Excel is opened, a workbook appears with three worksheets. Each worksheet contains columns and rows. There are 1,048,575 rows and 16,384 columns. The combination of a column coordinate and a row coordinate make up a cell address. For example, the cell located in the upper left corner of the worksheet is cell A1, meaning column A, row 1. The cell address is visible in the Name Box. 
Place your cursor in the first cell, A1. The formula bar will display the cell address in the Name Box on the left side of the Formula bar. Notice that the address changes as you move around the sheet. You can easily move from cell to cell by pressing tab or using the arrow keys. 

A cell can contain any of the following:

· A number (and any associated punctuation, such as decimal points, commas, and currency symbols).

· Text (including any combination of letters, numbers, and symbols that aren't number-related).

· A formula, which is a math equation.
· A function, which is a named equation that shortcuts an otherwise complex operation.
Creating a New Workbook

It is easy to create a new workbook! Simply, click on Office Button – New and click on Blank Workbook to create a new workbook.

Creating a New Worksheet

Creating a new worksheet is just as easy. By default, each Excel workbook contains three worksheets. Three tabs displaying Sheet 1, Sheet 2, and Sheet 3 will be displayed at the bottom of the workbook to indicate the separate sheets. To add a new worksheet, simply click on the tab after the tab that says Sheet 3.
Exercise 1
1. To change the location of a newly added worksheet, click once on the tab and hold down the left mouse button and drag the worksheet to its new location.

2. It is also possible to change the name of each worksheet. Right-click on the Sheet 1 tab and left-click on Rename. Once you click on Rename, the name of the sheet becomes highlighted and you can simply type in a new name. Double-clicking on the tab will also enable you to type in a new name.
3. You can also change the color of the tabs by right-clicking on the tab and choosing Tab Color.  Then simply choose a color!!!
4. It is possible to change the magnification of a worksheet so that you can read it better. To do this, click on View and then Zoom. Go ahead and try the different magnifications to see which works best for you. You can also make use of the Zoom bar in the lower right-hand corner to zoom to a comfortable reading size.
Navigating and Selecting 
Moving around a worksheet is easy! You can easily move from cell to cell by using the arrow keys or pressing tab (will move the cursor to the right) or shift-tab (shift-tab will move you to the left). You can also use your mouse to click within a cell which will select that cell. Sometimes you will want to select a range of cells.

A range is a group of one or more cells. If you select more than one cell at a time, you can then perform actions on the group of them at once, such as applying formatting or clearing the contents. A range can even be an entire worksheet.
A range is referenced by the upper left and lower right cells. For example, the range of cells B1, B2, C1, and C2 would be referred to as B1:C2.

To select a range:
· With the mouse: Drag across the desired cells with the left mouse button held down. Be careful when you're positioning the mouse over the first cell (before pressing the mouse button). Position the pointer over the center of the cell, and not over an edge.

If you drag while the pointer is on the edge of the cell, Excel interprets the selection as a move operation and whatever is in the cell(s) is dragged to a different spot.

· With the keyboard: Select the first cell, and then hold down the Shift key while you press the arrow keys to expand the selection area.

To select a nonrectangular or noncontiguous range, select the first portion of the range (that is, the first rectangular piece), and then hold down the Ctrl key while you select additional cells/ranges with the mouse.
To select an entire column, click the column header (where the letter is). To select an entire row, click the row header (where the number is). You can click one row or column and then drag to select additional columns, or hold down Ctrl as you click on the headers for noncontiguous rows and/or columns.

Exercise 2
Let’s practice:

1. Click column B's letter to select that column.

2. Hold Shift and click column D's letter. Columns B, C, and D should all be selected.

3. Release the Shift key.

4. Hold Ctrl and click column G's letter. Now B, C, D, and G are all selected.

5. Release the Ctrl key.

6. Click row 2's number. The columns are deselected, and row 2 is now selected.

7. Click in cell B4. The row is no longer selected, because you weren't holding down Shift or Ctrl. Now only B4 is selected.

8. Press and hold the Shift key while pressing the down arrow key two times. Now B4 through B6 are selected. This range is called B4:B6.

9. Still pressing the Shift key, press the right arrow two times. Now the range B4:D6 is selected.

10. Release the Shift key and then press and hold the Ctrl key.

11. Drag across cells B9, C9, and D9. Those cells are selected in addition to B4:D6.

12. Release the Ctrl key.

13. Press Ctrl+A. This is a shortcut for selecting the entire sheet.

14. Click in any cell to undo the selection.

15. Click the square containing a gray triangle at the upper intersection of the column letters and the row numbers. The entire sheet is selected again.
Entering and Editing Data
Let’s learn how to enter data into your worksheet. First, you place the cursor in the cell in which you would like to enter data. Then you type the data and press Enter.

Exercise 3
1. Place the cursor in cell A1.

2. Type Jane. Tab to the next cell and type Smith. 

3. Move the cursor back to cell A1.

4. Change "Jane" to "Joe."

You can also edit information in a cell by double-clicking in a cell or by clicking in the formula bar. Try these two options.
Let’s practice a little. 

Exercise 4
1. Click on the Office button and then on Open. 
2. Click on Desktop and then look for Business Trips.xls.

3. Double-click on the file.
4. Edit the text in cell A1 to read Gross Receipts Summary.

5. Change the value in cell D5 to 18.

6. Change the value in cell G12 to 28.

7. Change the value in cell J18 to 25.

8. In cell A19, type # nights @ $155.

9. In cell A18, change the text to read # nights @ $95.

10. In cell A17, select the cell and press the Delete key, clearing that cell's contents.

11. In cell K11, type December, and then press Enter.

12.  In cell K17, type December, and then press Enter.

13. In cell K18, type 16, and then press Enter.

14. In cell K19, type 2, and then press Enter.
15. Click on the Save button in the Quick Access Bar.
Inserting Columns and Rows 
If you don't plan your worksheet layout correctly, you might end up with too many or too few rows or columns in a certain area. You can always move data around in the sheet to help with this, but sometimes it's easier to simply insert or remove columns or rows.

Exercise 5
To insert a column or row:

1. Click on the cell on the right of the two columns between which you wish to insert. To insert rows, click on the lower row of the two between which you wish to insert. 
2. Go to “Insert” and select “Columns”. To insert a row, go to “Insert” and select “Rows”.
3. Appearing to the left of your highlighted column or above your highlighted row will be a new row or column.  Insert a row to the left of Column I and a row under Row 1.
Formatting Columns and Rows
Often you will need to change your columns and rows in order for text to fit or for the text to fit on the page correctly. There are a number of different methods one can use to do this. Let’s start with columns.

Column Width: The formatting that is unique to columns is Column Width. Column Width is measured in characters. A column's width can be from 0 to 255 characters, which is a really wide column! Decimal values are allowed. In fact, the default size is 8.43 characters.

 A width of 12, for example, means the column is wide enough for 12 average characters, using whatever you chose as the Standard font. The default is Calibri 11 pts. To change the font from the default, go to Tools-Options-General-Standard font. 

Column Width 
Exercise 6 – Autofit all

1. Move your pointer to the right edge of the heading of Column A until it changes to [image: image5.png]


 which is the Resize Column shape.

2. Press the left mouse button down. (Don't release it yet.)The popup tip appears, showing the current width of Column A.

3. Release the left mouse button and double-click in the same spot (the right edge of Column A's heading). The column width changes so it is wide enough to display the longest text in any cell in the column as a single line.

Be careful when you set a column's width with AutoFit. The column may wind up wider than you expected. Any text will be on a single line in its cell. No matter how long the text is! If you accidentally find you've widened a cell out of sight to the right, use Undo. (my favorite button!) Then resize the column with another method.

Column Width - Drag
Dragging is a natural method of adjusting column width. But since you can't see the change until you release the mouse button, it may take you several attempts to get a satisfactory width.

Exercise 7
1. Type in New Zealand in B1. Move the pointer to the right edge of column heading B.

2. When the pointer changes to [image: image6.png]


 (the Resize Column shape), drag to the right until New Zealand shows entirely. Since the column is not resized until you release the mouse button, you may need several tries to get the width right. 

3. Click and hold again on the right edge of Column B to see the new width.

Row Height

The only unique formatting for rows is Row Height. Row Height is measured in points, like font size, from 0 to 409 points. A row height of zero hides the row. 

The default setting for Row Height is AutoFit. The row height adjusts to the largest font size in the row. 

AutoFit will leave a little white space, called the cell padding, between the text in the cell and the cell edges. When Arial 10 pt. is the Standard Font, the Row Height is 12.75 points. You may find that this looks a bit crowded when the gridlines are shown. If you don't print the gridlines, your paper version will look OK.
Moving to a New Worksheet
In Microsoft Excel, each workbook is made up of several worksheets. Before moving to the next topic, let’s move to a new worksheet. You can move from worksheet to worksheet by clicking on the tabs at the bottom of the worksheet. Let’s move to Sheet 2.
Formatting Text and Data 
Once information has been entered into a cell, you might want to change or enhance the way the information is displayed. Text can be formatted in the same way that one uses in Microsoft Word or PowerPoint. Most of the formatting choices can be found in the Font grouping under the Home tab. There are numerous ways to format data. Let’s look at some. First remember to always make sure that the cell you want to format is selected.
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Using Formatting Buttons – On the Ribbon, make sure the Home tab is selected. In the Number Group box, there are several buttons which allow one-click formatting.
Exercise 8
1. Type in the number 214567 in Cells A1, B1, C1, and D1.

2. With the cursor in A1, click on the Currency button.
3. With the cursor in B1, click the Percent button.
4. To add decimal places, click the Increase Decimal button for cell C1.
5. To decrease decimal places, click the Decrease Decimal button for cell D1.
6. Type in 345678 in E1. Click on the Comma button to separate thousands.

Notice how each number changes depending on the formatting.
Formatting Numbers
Let’s look at other formatting options. 

Exercise 9                                



1. Move the cursor to cell A5.
2. Type 145657800. Hit enter and then move back into A5. At this point it is necessary to move out of the cell and then back in. I’m not sure why, but it is the only way to get the appropriate menu up!

3. Right click on the number. A menu will pop up. Click on Format Cells.
4. Click on “Number”. Click on the comma.
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The thousands should now be separated by commas.
After formatting
Let’s change it to a dollar amount.

1. Make sure that the cursor is in cell A5.

2. Right-click again.
3. Click on Format Cells.
4. Click Currency in drop down menu.
5. Look at the options available including currency symbols. 
Deleting vs Clearing a Cell
Many beginners get confused about clearing versus deleting in Excel, so let's look at this concept briefly. When you clear the content from a cell, the formatting for that cell is still there. It may be helpful to think of an Excel worksheet as a stack of empty cardboard boxes, each one with its open side facing you. You can put something into a cell or take something out. When you take something out of a cell, it's called clearing its content. The cell itself remains in the "stack," but it's now empty. 
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To clear the content from a cell: 
1. Press Delete on the keyboard. 
2. Right-click the cell and then select Clear Contents. 

3. On the Home tab, in the Editing group, select Clear > Clear Contents.
Unfortunately, clearing a cell's content doesn't clear its formatting. 
To clear formatting:

1. On the Home tab, in the Editing group, select Clear > Clear Formats
2. To clear both contents and formats at once, select Clear All.

In contrast, deleting the cell removes the cell itself from the stack and makes the surrounding cells shift. Think about what happens when you pull a box out of a stack of boxes -- the boxes above it fall down one position, right? It's the same thing with Excel cells, except it's reverse-gravity (cells fall up rather than down), and you have the choice of making the remaining cells shift up or to the left. Let’s look at how this works. 
Filling Cells Automatically
You can use Microsoft Excel to fill cells automatically with a series. For example, you can have Excel automatically fill in times, the days of the week or months of the year, years, and other types of series. Days of the week and months of the year fill in a similar fashion. 

Exercise 10
1. Let’s move to another worksheet.

2.  In cell A1, type Sunday.
3.  Find the small black square in the lower right corner of the highlighted area. This is called the Fill Handle. 
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 Grab the Fill Handle and drag with your mouse to fill cell A1 to G1. Note how the days of the week fill the cells in a series. Also, note that the Auto Fill Options icon appears. 
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5. Click the Auto Fill Options icon. Click on Copy Cells.
6. Choose the Fill Series radio button. The cells fill as a series from Sunday to Saturday again.

7. Click the Auto Fill Options icon again.

8. Choose the Fill Without Formatting radio button. The cells fill as a series from Sunday to Saturday, but the entries are not bolded.

9. Click the Auto Fill Options icon again.

10. Choose the Fill Weekdays radio button. The cells fill as a series from Monday to Friday.

Filling Time

Exercise 11
1. Click on a new worksheet. Type 1:00 into cell A1.

2. Grab the Fill Handle and drag with your mouse to highlight cells A1 to A24. Note that each cell fills using military time.

3. Click anywhere on the worksheet to remove the highlighting.

To change the format of the time:

1. Select cells A1 to A24.

2. Choose from the Ribbon: Home > Number.
3.  Click on the drop down box and choose Time.
4. The time is no longer in military time.    
5. If you wish to change the formatting further, click on the dropdown arrow in lower right-hand corner of number group and choose the way you want the time to appear.
Filling in Numbers

Exercise 12
1. Click on another worksheet. Type a 1 in cell A1.

2.  Grab the Fill Handle and drag with your mouse to highlight cells A1 to A7. The number 1 fills each cell.

3.  Click the Auto Fill Options icon.

4.  Choose the Fill Series radio button. The cells fill as a series starting with 1, 2, 3.

And finally, here is one more interesting fill feature.

1. Go to cell A1.

2. Type Lesson 1.

3. Grab the Fill Handle and drag with your mouse to highlight cells A1 to A6. 

4. The cells fill in as a series: Lesson 1, Lesson 2, Lesson 3, and so on.

Alignment Options:  Wrapping Text
When you enter text that is too long to fit in a cell into a cell, it overlaps the next cell. If you do not want it to overlap the next cell you can wrap the text.

Exercise 13
1. Open another new sheet. 

2. Move to cell A1.

3. Type Text too long to fit. (After typing, click out of the cell and back in again.)
4. From the Ribbon, choose Home >Cells > Format. This will open a dropdown menu.
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Click on Format Cells at the bottom of the dropdown menu. 

6. Choose the Alignment tab.

7. Click Wrap Text.

8. Click OK. The text wraps.
Merging Cells

Sometimes, rather than having text wrap in a cell, you will actually want the text to run across the width of the data. Usually when making a spreadsheet, you need to create a heading for the sheet. This heading should run across the width of your data.  To do this, one must merge the cells across the width of the data.

Exercise 14
1. Select the range A1:B1. 
2. Click [image: image7.png]


 the Merge and Center button. The heading is now centered over the data.
Performing Mathematical Calculations      
Let’s add a column of numbers using the AutoSum Button [image: image8.png]


. To select the AutoSum button choose Home > Editing > [image: image9.png]


 and automatically add a column of numbers.  
Exercise 16
1. Type in the numbers 5, 7, 3, 9, 4, 8 in column C.
2. Move your cursor to select C7. Click the AutoSum button [image: image10.png]


 found on the Ribbon under Home > Editing.
3. C1 to C6 should now be highlighted.
4. Press Enter. Cells C1 through C6 are added together.
What's a formula?

A formula is an equation that performs some type of operation and issues a result. In Excel, formulas always begin with an equal sign. Here are some formula examples:

· =2+6: This formula is strictly math. If you place this formula in a cell, the cell displays 8.
· =A1+6: Same as the preceding, but this time you're adding 6 to whichever value is in cell A1 and displaying the result in the cell into which you enter this formula. This formula does not change A1's contents.

· =A1+A2: Same thing again, but you're adding the contents of cell A1 to the contents of cell A2.

· =A1+A2-A3: In this example, multiple cells are referenced.

Here are the symbols you can use in formulas to indicate mathematical operations:

· +: Addition

· -: Subtraction

· *: Multiplication

· /: Division

Exercise 16
To try a basic formula, do the following:

1. In a new worksheet, type 6 in cell A1 and 7 in cell A2.
2. In cell A3, type =A1+A2, and then press Enter.
3. Select cell A3. Notice that it displays 13 in the cell itself, and in the formula bar, the original formula you entered appears.

4. Click in the formula bar to move the insertion point there and edit the formula to read as follows: =A1+A2+5. Then press Enter. The value now appears as 18.
5. Change the value in cell A1 to 4. The value in A3 changes to 16.
More Formula Examples

The math operators in Excel have an order of operation, just like in regular math. The order of operation is the order in which they're processed when multiple operators appear in the same formula. Here are the rules that determine the order:
1. Any operations that are in parentheses, from left to right

2. Multiplication (*) and division (/)

3. Addition (+) and subtraction (-)
Parentheses override everything and go first. So, if you need to execute an operation out of the normal order, you place it in parentheses. Now let's try some formula examples that refer to cells and use math operations. For this exercise, enter the following values in cells in a blank worksheet:  
A1: 12
A2: 6
A3: 4
A4: 9
Exercise 17
Now let’s create the following formulas:
1. In cell A5, create a formula that adds A1+A2+A3+A4.
2. In cell A6, create a formula that adds A1+A2, and then multiplies the result by the sum of A3+A4. (Remember, operations that you want to perform first should be put in parenthesis.)
3. In cell A7, create a formula that adds A1+A2+A3+A4 and then divides the result by 4.
4. In cell A8, create a formula that first calculates A1+A4 and then divides it by A3.
5. Here are the correct answers!
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Printing

Let’s prepare to print! If your worksheet is more than one printed page, it is possible to have the heading on each page by going to the Page Layout tab, in the Page Setup group and click Print Titles. 
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On the Sheet tab, under Print Titles, do one or both of the following: 
In the Rows to repeat at top box, type the reference of the rows that contain the column labels if you want the heading repeated on each page.

In the Columns to repeat at left box, type the reference of the columns that contain the row labels if you want those to show.
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We want our sheet to print with no gridlines, and centered horizontally across the page, but not vertically. Let’s go the Page Layout > Sheet Options.  There should not be a check under Print in the Gridline section. 

Make sure that you have checked your spelling and made any necessary corrections. Click on the Office Button and Print>Print Preview (Always do a print preview in Excel!). Click on Page Setup>Margins and make sure that there is a check under “Center on Page” > horizontally. Now let’s print!!! 
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Recognizing Cursor Styles 
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	Click and drag to highlight multiple cells with this cursor, or click in a cell to select the single cell
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	Click and drag with this cursor to fill cell contents into cells below or to the right.
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	Click and drag the contents of the selected cell to any other cell.
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	Click to place the cursor into the Formula bar so that you can edit an equation or function.


There are four common cursor styles used in Excel.
Common formula errors

Here are some of the most common mistakes people make when entering formulas and functions:

· Not putting in all the required arguments: If a function is expecting more arguments than you have entered, and you get a dialog box, be sure you've placed commas between the arguments and that you haven't overlooked any.

· Circular references: If you refer to the cell's own address in a function, you create a circular error, which is like an endless loop. Suppose that you enter =A1+1 into cell A1. You'll get an error message like the one below. If you click OK at this message, a Help window appears to help you find the problem.
· Text in an argument: Most functions require numeric arguments. If you enter text as an argument, for example, =SUM(text), the word #NAME? appears in the cell. This happens because Excel allows you to name ranges of cells using text, so technically =SUM(text) isn't an invalid function. It is invalid only if there's no range that has been assigned the name "text."

· Hash marks (###) in a cell: This happens when the cell isn't wide enough to display its value. Widen the column to fix this.

If you receive an error when copying a formula, don't panic; it happens to everyone. Use the skills you learned earlier in this chapter to display the formulas and then check them for the common errors discussed here.
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In addition to the books, here are free online tutorials that can help you with Microsoft Excel.

HP Learning Center:  http://h30187.www3.hp.com/ 

Microsoft:  http://office.microsoft.com/en-us/excel/FX100646951033.aspx
Goodwill Industries:  http://www.gcflearnfree.org/
Baycon Group:  http://www.baycongroup.com/el0.htm
Internet4Classrooms: http://www.internet4classrooms.com/on-line_excel.htm
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